Help Center Manage My Account Was FUEL TV+ affected by Heartbleed?

Was FUEL TV+ affected by Heartbleed?

The recent OpenSSL vulnerability known as "Heartbleed" has affected many Internet services and websites. Heartbleed can reveal the contents of a server's memory, where most sensitive data is stored. The bug appears in OpenSSL versions 1.0.1 to 1.0.1f.

FUEL TV+ was not affected by this vulnerability because we were never running a vulnerable version of OpenSSL on our servers.

However, as a precaution, please consider changing your FUEL TV+ password especially if you used the same password elsewhere.